Maxine for V4.2

Description:

Maxine character for V4.2.

Requirements: Poser 6 or higher, V4.2, DazMorphs++ for V4.2

Support Link:

http://www.renderosity.com/mod/bcs/maxine-for-v4-2/70799

Download links:

MEGA GOOGLE DRIVE

Add a Comment

Your email address will not be published. Required fields are marked *